$re = '/(["\'])(?:(?=(\\\\?))\2.)*?\1/m';
$str = '"hello world\\" qsd " qdqd "
" hello world "
" hello world \\"
I have a value like this "Foo Bar" "Another Value" something else
I have a value like this "Foo Bar" "Another Value".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);