#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(["'])(?:(?=(\\?))\2.)*?\1"
Local $sString = ""hello world\" qsd " qdqd "" & @CRLF & _
" " hello world "" & @CRLF & _
" " hello world \"" & @CRLF & _
"I have a value like this "Foo Bar" "Another Value" something else" & @CRLF & _
"I have a value like this "Foo Bar" "Another Value"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")