using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""'])(?:(?=(\\?))\2.)*?\1";
string input = @"""hello world\"" qsd "" qdqd ""
"" hello world ""
"" hello world \""
I have a value like this ""Foo Bar"" ""Another Value"" something else
I have a value like this ""Foo Bar"" ""Another Value"".";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}