re = /^(['"])((?:\\.|(?!\1).)*+)\1$/m
str = '\'hello world\'
\'here\\\'s my foo\'
\'Im at my friends\\\'
"\\"hello\\", he said "
"that\'s a backslash: \\\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end