using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(['""])((?:\\.|(?!\1).)*+)\1$";
string input = @"'hello world'
'here\'s my foo'
'Im at my friends\'
""\""hello\"", he said ""
""that's a backslash: \\""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}