$re = '/^([\'"])((?:\\\\.|(?!\1).)*+)\1$/m';
$str = '\'hello world\'
\'here\\\'s my foo\'
\'Im at my friends\\\'
"\\"hello\\", he said "
"that\'s a backslash: \\\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);