$re = '/(https://)?discord\.com/invite/[a-zA-Z0-9]+/m';
$str = 'https://discord.com/invite/J8BDpEpnj7
discord.com/invite/J8BDpEpnj7
discord.com/invite/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);