package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https://)?discord\.com/invite/[a-zA-Z0-9]+`)
var str = `https://discord.com/invite/J8BDpEpnj7
discord.com/invite/J8BDpEpnj7
discord.com/invite/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}