#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https://)?discord\.com/invite/[a-zA-Z0-9]+"
Local $sString = "https://discord.com/invite/J8BDpEpnj7" & @CRLF & _
"discord.com/invite/J8BDpEpnj7" & @CRLF & _
"discord.com/invite/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")