use strict;
my $str = 'http://www.safesteptub.com/thank-you
http://www.safesteptub.com/email/thank-you/
NOTE:
Newlines are excluded as well. Please make sure the string you want to test is at the top of the list.
';
my $regex = qr/^((?!.*email).)*thank(\-|\_|)you.*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}