#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^((?!.*email).)*thank(\-|\_|)you.*"
Local $sString = "http://www.safesteptub.com/thank-you" & @CRLF & _
"http://www.safesteptub.com/email/thank-you/" & @CRLF & _
"" & @CRLF & _
"NOTE: " & @CRLF & _
"" & @CRLF & _
"Newlines are excluded as well. Please make sure the string you want to test is at the top of the list." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")