import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!.*email).)*thank(\\-|\\_|)you.*";
final String string = "http://www.safesteptub.com/thank-you\n"
+ "http://www.safesteptub.com/email/thank-you/\n\n"
+ "NOTE: \n\n"
+ "Newlines are excluded as well. Please make sure the string you want to test is at the top of the list.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}