$re = '/^url\(\s*?([\'"]?)([^\'"()]+?)\s*\1\s*\)$/';
$str = 'url(./2.png)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);