using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^url\(\s*?(['""]?)([^'""()]+?)\s*\1\s*\)$";
string input = @"url(./2.png)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}