const regex = /^url\(\s*?(['"]?)([^'"()]+?)\s*\1\s*\)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^url\\(\\s*?([\'"]?)([^\'"()]+?)\\s*\\1\\s*\\)$', '')
const str = `url(./2.png)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}