$re = '/2\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[1,2][0-9]|3[0,1])/m';
$str = 'mano data yra tokia:L 2014-11-22 areba 2013-09-23. Va tiek.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);