use strict;
my $str = 'mano data yra tokia:L 2014-11-22 areba 2013-09-23. Va tiek.';
my $regex = qr/2\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[1,2][0-9]|3[0,1])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}