package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)2\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[1,2][0-9]|3[0,1])`)
var str = `mano data yra tokia:L 2014-11-22 areba 2013-09-23. Va tiek.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}