re = /^(?:ISBN(?:-10)?:? )?(?:(?<number>\d{9})|(?=[\dX -]{13}$)(?<registrationGroup>\d{1,5})[ -](?<registrant>\d{1,7})[ -](?<publication>\d{1,6})[ -])(?<checkDigit>[\dX])$/m
str = '359821508X
3598215083X
35982150X
3-598-21508-8
3-598-215087-8
3-598-2150-8
3598-2150-8
359821-5-0-8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end