#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:ISBN(?:-10)?:? )?(?:(?<number>\d{9})|(?=[\dX -]{13}$)(?<registrationGroup>\d{1,5})[ -](?<registrant>\d{1,7})[ -](?<publication>\d{1,6})[ -])(?<checkDigit>[\dX])$"
Local $sString = "359821508X" & @CRLF & _
"3598215083X" & @CRLF & _
"35982150X" & @CRLF & _
"3-598-21508-8" & @CRLF & _
"3-598-215087-8" & @CRLF & _
"3-598-2150-8" & @CRLF & _
"3598-2150-8" & @CRLF & _
"359821-5-0-8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")