import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:ISBN(?:-10)?:? )?(?:(?<number>\\d{9})|(?=[\\dX -]{13}$)(?<registrationGroup>\\d{1,5})[ -](?<registrant>\\d{1,7})[ -](?<publication>\\d{1,6})[ -])(?<checkDigit>[\\dX])$";
final String string = "359821508X\n"
+ "3598215083X\n"
+ "35982150X\n"
+ "3-598-21508-8\n"
+ "3-598-215087-8\n"
+ "3-598-2150-8\n"
+ "3598-2150-8\n"
+ "359821-5-0-8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}