$re = '/Let\'s start(.*[\r\n])*.*my friend\./m';
$str = 'How much wood? Who knew! Let\'s start! ... blah, blah, blah...
How much
longer? It\'s joe\'s place*, isn\'t it?
This is! [the end], my friend. Ok, Let\'s do some more testing.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);