using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Let's start(.*[\r\n])*.*my friend\.";
string input = @"How much wood? Who knew! Let's start! ... blah, blah, blah...
How much
longer? It's joe's place*, isn't it?
This is! [the end], my friend. Ok, Let's do some more testing.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}