package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Let's start(.*[\r\n])*.*my friend\.`)
var str = `How much wood? Who knew! Let's start! ... blah, blah, blah...
How much
longer? It's joe's place*, isn't it?
This is! [the end], my friend. Ok, Let's do some more testing.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}