// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(?:"[^"]+"|'[^']+')|(?<G><\s?(\w+).*\/>)"#).unwrap();
let string = " <div>
TESAT ${this.TT1}
${am.map( (item, i) => `<li>${item}</li>${i}`).join('')}
<Label width=\"100px\" behaviour=\"fixed\" />
< Label123 width=\"100px\" behaviour=\"fixed\" />
\"<Label123 width=\"100px\" behaviour=\"fixed\"/>\"
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}