re = /(?:"[^"]+"|'[^']+')|(?<G><\s?(\w+).*\/>)/mi
str = ' <div>
TESAT ${this.TT1}
${am.map( (item, i) => `<li>${item}</li>${i}`).join(\'\')}
<Label width="100px" behaviour="fixed" />
< Label123 width="100px" behaviour="fixed" />
"<Label123 width="100px" behaviour="fixed"/>"
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end