const regex = /(?:"[^"]+"|'[^']+')|(?<G><\s?(\w+).*\/>)/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"[^"]+"|\'[^\']+\')|(?<G><\\s?(\\w+).*\\\/>)', 'mig')
const str = ` <div>
TESAT \${this.TT1}
\${am.map( (item, i) => \`<li>\${item}</li>\${i}\`).join('')}
<Label width="100px" behaviour="fixed" />
< Label123 width="100px" behaviour="fixed" />
"<Label123 width="100px" behaviour="fixed"/>"
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}