const regex = /^(?:(?:https?:\/\/)?(?:(?:www|s|i2)\.)?(?:youtu\.?be|ytimg)(?:\.com)?\/)(?:watch\?v=|v\/|yt\/favicon|oembed\?|vi\/)?(?:url=http%3A\/\/www\.youtube\.com\/watch\?v%3D)?([a-zA-Z0-9_-]*).*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:https?:\\\/\\\/)?(?:(?:www|s|i2)\\.)?(?:youtu\\.?be|ytimg)(?:\\.com)?\\\/)(?:watch\\?v=|v\\\/|yt\\\/favicon|oembed\\?|vi\\\/)?(?:url=http%3A\\\/\\\/www\\.youtube\\.com\\\/watch\\?v%3D)?([a-zA-Z0-9_-]*).*?$', 'gm')
const str = `https://www.youtube.com/watch?v=Gge6Hg2-RVM
http://www.youtube.com/watch?v=-wtIMTCHWuI
http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1
http://youtu.be/-wtIMTCHWuI
http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json
http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico
http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}