package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:https?:\/\/)?(?:(?:www|s|i2)\.)?(?:youtu\.?be|ytimg)(?:\.com)?\/)(?:watch\?v=|v\/|yt\/favicon|oembed\?|vi\/)?(?:url=http%3A\/\/www\.youtube\.com\/watch\?v%3D)?([a-zA-Z0-9_-]*).*?$`)
var str = `https://www.youtube.com/watch?v=Gge6Hg2-RVM
http://www.youtube.com/watch?v=-wtIMTCHWuI
http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1
http://youtu.be/-wtIMTCHWuI
http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json
http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico
http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}