import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:https?:\\/\\/)?(?:(?:www|s|i2)\\.)?(?:youtu\\.?be|ytimg)(?:\\.com)?\\/)(?:watch\\?v=|v\\/|yt\\/favicon|oembed\\?|vi\\/)?(?:url=http%3A\\/\\/www\\.youtube\\.com\\/watch\\?v%3D)?([a-zA-Z0-9_-]*).*?$";
final String string = "https://www.youtube.com/watch?v=Gge6Hg2-RVM\n\n"
+ "http://www.youtube.com/watch?v=-wtIMTCHWuI\n\n"
+ "http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n\n"
+ "http://youtu.be/-wtIMTCHWuI\n\n"
+ "http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n\n"
+ "http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico\n\n"
+ "http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}