import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+[\\d]{11,14}";
final String string = "Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/\n"
+ "IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:\"{};'[]|\\<>?,./\n"
+ "IVANOV Ivan !@#$$^&*(_+1234567890-=~`:\"{};'[]|\\<>?,./\n"
+ "+9991234567\n"
+ "+19991234567\n"
+ "+129991234567\n"
+ "+1239991234567\n"
+ "+12349991234567\n"
+ "+1 999 1234567\n"
+ "+1234 (999) 123-45-67\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}