package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\+[\d]{11,14}`)
var str = `Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~\`:"{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~\`:"{};'[]|\<>?,./
+9991234567
+19991234567
+129991234567
+1239991234567
+12349991234567
+1 999 1234567
+1234 (999) 123-45-67
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}