# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+[\d]{11,14}//gi;t' <<< "Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:\"{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:\"{};'[]|\<>?,./
+9991234567
+19991234567
+129991234567
+1239991234567
+12349991234567
+1 999 1234567
+1234 (999) 123-45-67
"