$re = '/\d+:\d+\s+(?:.*?",")(?<user>[^"]+)(?:.*?",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<src>[^"]+)(?:",")(?<dst>[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<action>[^"]+)(?:.*?",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<svc>[^"]+)(?:.*?",")(?<application>[^"]+)(?:.*?",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<ruleName>[^"]+)(?:.*?",")/m';
$str = 'Fri Feb 24 23:45:52 2023","San Francisco->San Francisco->SFO-Servers","Default Department","San Francisco->San Francisco->SFO-Servers","53","53544","53","39474","172.17.129.110","156.154.71.5","104.129.192.104","128.177.129.156","157.130.202.234","0","GRE","Allow","Yes","Yes","No","DNS","dns","UDP","Miscellaneous or Unknown","United States","1","Default Allow","143","86","0","1","1","None","None","None","NA","NA"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);