using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+:\d+\s+(?:.*?"","")(?<user>[^""]+)(?:.*?"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?<src>[^""]+)(?:"","")(?<dst>[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?<action>[^""]+)(?:.*?"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?<svc>[^""]+)(?:.*?"","")(?<application>[^""]+)(?:.*?"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?:[^""]+)(?:"","")(?<ruleName>[^""]+)(?:.*?"","")";
string input = @"Fri Feb 24 23:45:52 2023"",""San Francisco->San Francisco->SFO-Servers"",""Default Department"",""San Francisco->San Francisco->SFO-Servers"",""53"",""53544"",""53"",""39474"",""172.17.129.110"",""156.154.71.5"",""104.129.192.104"",""128.177.129.156"",""157.130.202.234"",""0"",""GRE"",""Allow"",""Yes"",""Yes"",""No"",""DNS"",""dns"",""UDP"",""Miscellaneous or Unknown"",""United States"",""1"",""Default Allow"",""143"",""86"",""0"",""1"",""1"",""None"",""None"",""None"",""NA"",""NA""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}