import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+:\\d+\\s+(?:.*?\",\")(?<user>[^\"]+)(?:.*?\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<src>[^\"]+)(?:\",\")(?<dst>[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<action>[^\"]+)(?:.*?\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<svc>[^\"]+)(?:.*?\",\")(?<application>[^\"]+)(?:.*?\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<ruleName>[^\"]+)(?:.*?\",\")";
final String string = "Fri Feb 24 23:45:52 2023\",\"San Francisco->San Francisco->SFO-Servers\",\"Default Department\",\"San Francisco->San Francisco->SFO-Servers\",\"53\",\"53544\",\"53\",\"39474\",\"172.17.129.110\",\"156.154.71.5\",\"104.129.192.104\",\"128.177.129.156\",\"157.130.202.234\",\"0\",\"GRE\",\"Allow\",\"Yes\",\"Yes\",\"No\",\"DNS\",\"dns\",\"UDP\",\"Miscellaneous or Unknown\",\"United States\",\"1\",\"Default Allow\",\"143\",\"86\",\"0\",\"1\",\"1\",\"None\",\"None\",\"None\",\"NA\",\"NA\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}