use strict;
my $str = 'ss.s.s+eee-eee_eeee@gmail.com é o meu email.
O e-mail a@a1-m.com.br também pertence @ mim.com.br!!!@cc.com
example@s.example
simple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
example-indeed@strange-example.com
admin@mailserver1
" "@example.org
"john..doe"@example.org
';
my $regex = qr/((?:\b(?!\.))(?!.*\.\..*)(?:[a-zA-Z0-9\.\-\+_\-]+?)?[a-zA-Z0-9]+?|\"\s\"|\"[a-zA-Z0-9]+?\.\.[a-zA-z0-9]+?\")@([a-zA-Z0-9]+(?:\-[a-zA-Z0-9])?\.?[a-zA-Z0-9]+(?:\.[a-zA-Z]+)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}