import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\b(?!\\.))(?!.*\\.\\..*)(?:[a-zA-Z0-9\\.\\-\\+_\\-]+?)?[a-zA-Z0-9]+?|\\\"\\s\\\"|\\\"[a-zA-Z0-9]+?\\.\\.[a-zA-z0-9]+?\\\")@([a-zA-Z0-9]+(?:\\-[a-zA-Z0-9])?\\.?[a-zA-Z0-9]+(?:\\.[a-zA-Z]+)?)";
final String string = "ss.s.s+eee-eee_eeee@gmail.com é o meu email. \n"
+ "O e-mail a@a1-m.com.br também pertence @ mim.com.br!!!@cc.com \n\n"
+ "example@s.example\n"
+ "simple@example.com\n"
+ "very.common@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "other.email-with-hyphen@example.com\n"
+ "fully-qualified-domain@example.com\n"
+ "user.name+tag+sorting@example.com\n"
+ "example-indeed@strange-example.com\n"
+ "admin@mailserver1\n"
+ "\" \"@example.org\n"
+ "\"john..doe\"@example.org\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}