const regex = new RegExp('((?:\\b(?!\\.))(?!.*\\.\\..*)(?:[a-zA-Z0-9\\.\\-\\+_\\-]+?)?[a-zA-Z0-9]+?|\\"\\s\\"|\\"[a-zA-Z0-9]+?\\.\\.[a-zA-z0-9]+?\\")@([a-zA-Z0-9]+(?:\\-[a-zA-Z0-9])?\\.?[a-zA-Z0-9]+(?:\\.[a-zA-Z]+)?)', 'gm')
const str = `ss.s.s+eee-eee_eeee@gmail.com é o meu email.
O e-mail a@a1-m.com.br também pertence @ mim.com.br!!!@cc.com
example@s.example
simple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
example-indeed@strange-example.com
admin@mailserver1
" "@example.org
"john..doe"@example.org
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}