re = /\/\*@\*\/([^*]+?)(\/\*@\*\/)/m
str = 'contactCell.headline = </span><span class="s3">/*@*/"Headline toBeReplaced by PropertyBag Entry"/*@*/</span><span class="s1">
contactCell.headline = /*@*/</span><span class="s4">4711/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span>someThing<span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing2</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing3</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end