#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\*@\*\/([^*]+?)(\/\*@\*\/)"
Local $sString = "contactCell.headline = </span><span class="s3">/*@*/"Headline toBeReplaced by PropertyBag Entry"/*@*/</span><span class="s1">" & @CRLF & _
" contactCell.headline = /*@*/</span><span class="s4">4711/*@*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span>someThing<span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing2</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing3</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> " & @CRLF & _
"" & @CRLF & _
" </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1"> " & @CRLF & _
" </span><span class="s2">/*@END showFloatValue*/</span><span class="s1">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")