use strict;
my $str = 'contactCell.headline = </span><span class="s3">/*@*/"Headline toBeReplaced by PropertyBag Entry"/*@*/</span><span class="s1">
contactCell.headline = /*@*/</span><span class="s4">4711/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span>someThing<span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing2</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing3</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1"> </span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">17.5</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">
</span><span class="s2">/*@BEGIN showFloatValue*/</span><span class="s1">
</span><span class="s0">val </span><span class="s1">floatValue = </span><span class="s2">/*@*/</span><span class="s3">someThing</span><span class="s2">/*@*/</span><span class="s1">
</span><span class="s2">/*@END showFloatValue*/</span><span class="s1">';
my $regex = qr/\/\*@\*\/([^*]+?)(\/\*@\*\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}