const regex = /\/(en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/+(lgl-platform)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\\\/+(lgl-platform)', 'gm')
const str = `/lgl-platform`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}