package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/+(lgl-platform)`)
var str = `/lgl-platform`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}