using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/+(lgl-platform)";
string input = @"/lgl-platform";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}