re = /\[\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]/mi
str = 'Test
Te[b]st[/b]
Tes[font]t[/font]
Test[Custom]Oh no![/Custom]
Test[color=red]With attr[/b][/i][/u][/color]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end