using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]";
string input = @"Test
Te[b]st[/b]
Tes[font]t[/font]
Test[Custom]Oh no![/Custom]
Test[color=red]With attr[/b][/i][/u][/color]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}