const regex = /\[\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]', 'mgi')
const str = `Test
Te[b]st[/b]
Tes[font]t[/font]
Test[Custom]Oh no![/Custom]
Test[color=red]With attr[/b][/i][/u][/color]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}