re = /^(((http|https):\/\/)+[www.])?\s*\S+\s*(.com|.es|.net|.org|.co)$/im
str = 'www.googlemcom
http://.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end