$re = '/^(((http|https):\/\/)+[www.])?\s*\S+\s*(.com|.es|.net|.org|.co)$/im';
$str = 'www.googlemcom
http://.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);